Very Low FPS on REBOOT KBOS

canonprince1989
Posts: 1

Very Low FPS on REBOOT KBOS

Post by canonprince1989 » Wed Feb 28, 2018 3:00 pm

I loved this scenery. But for some reason I got very low FPS in VC, like 12 to 15. I turned off the animated vehicles and snow effect. even turned off 3d grass.
My simulator is P3Dv4.1
PC spec is dell XPS-7800
GTX 1070 @8Gb
i7 4790K@4.0Ghz
RAM:16Gb

Addon: PMDG 777 orbx global and NA.
george[flytampa]
Site Admin
Posts: 3469

Re: Very Low FPS on REBOOT KBOS

Post by george[flytampa] » Wed Feb 28, 2018 3:51 pm

3D people have to most hit from our scenery options.

In Prepar, turn off water reflections & be careful with shadow options. Knock the water detail down too.

Using AI? Reduce it.

Boston is a dense city airport so don't expect miracles. It won't run much better with the stock scenery.
12g13008
Posts: 3

Re: Very Low FPS on REBOOT KBOS

Post by 12g13008 » Sun Dec 30, 2018 3:25 pm

I've been looking through this forum trying to find an answer to this problem; I have almost exactly the same computer specs as above, yet Boston is the one airport I have that performs with 10fps, noticeably this bad when looking at the terminal itself. I don't think dynamic lighting is the problem as I get the same fps during the day.

I have tried all the recommendations ( removing people, lowering certain settings ect) but despite this Boston is by far the worst performing scenery I have; as a comparison I get 30fps under the same conditions as Heathrow!

Any suggestions would be appreciated,

thanks
george[flytampa]
Site Admin
Posts: 3469

Re: Very Low FPS on REBOOT KBOS

Post by george[flytampa] » Sun Dec 30, 2018 4:10 pm

Remove all the terminal bgls and see if it makes a difference. It didn't for me.
Nothing I can do now. It's always been a tough area. The solution will have to come from optimization on Lockheed Martins side.

Heathrow runs poorly for me with AI. In fact, the default Heathrow runs at 8fps with 100% AI.
@Boston, I get 25fps WITH the scenery & 100% AI. Without AI, it can hit 50fps.
Attachments
bos.jpg
bos.jpg (262.51 KiB) Viewed 3481 times
lhr.jpg
lhr.jpg (337.88 KiB) Viewed 3481 times
12g13008
Posts: 3

Re: Very Low FPS on REBOOT KBOS

Post by 12g13008 » Sun Dec 30, 2018 6:15 pm

Thanks for the quick reply!

I removed all the terminal BGL's and now the fps (when looking at the terminal area) has increased to about 22fps on average. When looking at Boston city itself the fps is still in excess of 30fps.

Not sure what my setup particularly dislikes about the terminal buildings?

It's strange to compare Heathrow because I get 30fps there with addon scenery ect. As another comparison FlightBeam KSFO runs incredibly smoothly on my computer which is supposedly a very intensive scenery as well.

If there's a way to disable/ lower textures on the terminals I'd be happy to give that a go?

Thanks
george[flytampa]
Site Admin
Posts: 3469

Re: Very Low FPS on REBOOT KBOS

Post by george[flytampa] » Sun Dec 30, 2018 8:43 pm

What CPU & Graphics card do you have?

You could try lowering the texture resolution in the P3D settings. See if that helps.
12g13008
Posts: 3

Re: Very Low FPS on REBOOT KBOS

Post by 12g13008 » Mon Dec 31, 2018 3:32 pm

GTX 980ti
I5 4670k overclocked

The texture resolution doesn't make a difference unfortunately. I do use a 4K monitor but the performance is the same as before when I used a 1920 x 1080 monitor.
george[flytampa]
Site Admin
Posts: 3469

Re: Very Low FPS on REBOOT KBOS

Post by george[flytampa] » Mon Dec 31, 2018 9:25 pm

I'm on a older I7 and 1070. It might be that I5 struggling with certain elements.
zsolt.monostori
Posts: 17

Re: Very Low FPS on REBOOT KBOS

Post by zsolt.monostori » Fri Feb 22, 2019 2:04 pm

Reducing everything because of one scenery should not be consideted and accepted as a solution. There are way more complex areas in the world of flight simulation with just as detailed scenery add-ons covering them yet they perform well. San Francisco and the Bay Area is a similar environment yet I get almost double the FPS in a well known developer's airport. And it's just one example. And without reducing anything.

This is FlyTampa's worst ever release when it comes to performance. Since I bought it I couldn perform a flight without scratching my head. These days I avoid BOS like a plague as if I never even bought it.

This product needs some very srious optimizations. Fingers crossed, hopefully in the near future an update (maybe bringing PBR too) will put it back on my destination map.
george[flytampa]
Site Admin
Posts: 3469

Re: Very Low FPS on REBOOT KBOS

Post by george[flytampa] » Fri Feb 22, 2019 3:41 pm

zsolt.monostori wrote:Reducing everything because of one scenery should not be consideted and accepted as a solution. There are way more complex areas in the world of flight simulation with just as detailed scenery add-ons covering them yet they perform well. San Francisco and the Bay Area is a similar environment yet I get almost double the FPS in a well known developer's airport. And it's just one example. And without reducing anything.

This is FlyTampa's worst ever release when it comes to performance. Since I bought it I couldn perform a flight without scratching my head. These days I avoid BOS like a plague as if I never even bought it.

This product needs some very srious optimizations. Fingers crossed, hopefully in the near future an update (maybe bringing PBR too) will put it back on my destination map.

Let's have a look if any of this is true. Both airports tested with the entire airport and city in view.
Default SFO V Default BOS favors SFO by nearly double the frame rate. SFO even spikes to 80+
If Boston had an extra 30 fps overhead like SFO, even Zsolt's setup might have a cat in hells chance of running it. lol.
Attachments
ksfo.jpg
ksfo.jpg (480.53 KiB) Viewed 2951 times
kbos.jpg
kbos.jpg (626.92 KiB) Viewed 2951 times
zsolt.monostori
Posts: 17

Re: Very Low FPS on REBOOT KBOS

Post by zsolt.monostori » Thu Feb 28, 2019 6:22 pm

It's very easy (and very professional, cough, cough...) to "LOL" upon a customer that purchased your product instead of looking for ways of fixing the issue. Basically, you grabbed a crappy default scenery for comparison from one certain angle. This isn't proof for anything. I tested without your KBOS installed (but still with FTX Global, Vector, OpenLC NA) installed and using the exact same settings that I always had and I got 55 FPS. How come I have more FPS with all these ORBX products installed than you, without anything... Now what? It still proves absolutely nothing.

On the other hand, basically you are "telling" that in the whole FS world the area of KBOS is the most FPS demanding of them all. Because among all the scenery products that I currently own, KBOS is by far the worst performing and I have quite a few sceneries including some of the most complex ones:

FSDT KJFK, KLAX, KSDF, KMEM, KIAH, KCLT
Aerosoft EGLL, EDDF
Taxi2Gate LFPG, VHHH, KSEA, EDDM
Flightbeam KPDX, KIAD, KSFO, KPHX, KMSP
Imaginesim KATL, WSSS
LatinVFR KMIA, SCEL
Justsim UUWW, EBBR
Drzewiecki UUEE, NY Airports V2, Seattle Airports and City, UBBB
Or FlyTampa's very own CYYZ, CYUL, EHAM, EKCH...

just to name a very few... What you are suggesting is that from all of these, the totally average city of Boston is the worst performing by default, just to justify the crappy performance of your product...

This is utter nonsense. The area of KBOS isn't any more complex than most of these and Boston itself isn't even a megapolis like New York, Los Angeles, Paris, London, Moscow, Singapore, not even talking about the airport itself which is a medium sized airport, especially compared against the most of those listed above. I have zero issues in any of the above airports, they all give acceptable FPS consistently, be it day or night, rain or shine, cloudy or clear skies. In your KBOS, without AI, during night time, I get 17-18 FPS parking at gate E8 in the cockpit of the QW 787 facing ahead.

No, it's not the Boston area. The problem is the Flytampa KBOS airport scenery itself. Meanwhile the above listed products are properly optimized, your KBOS isn't. Airports way bigger, cities much larger, areas more complex and more dense result in excellent performance meanwhile your KBOS gives substandard FPS, even with many of the FlyTampa features such as snow drift, 3D people etc. disabled.

This cannot be explained away by blaming it on the area. If other developers manage to produce similarly complex airports so that they don't devour FPS like a hungry beast then it's fair to expect the same from a FlyTampa product too. This before, the FlyTampa CYYZ was also kind of rough but still better performance wise, but the latest (PBR) update tamed it very much. Don't know what else was done to it but I observed significant FPS gain after the update. Nothing I did observe however after the latest KBOS update, still as horrible as ever.

Instead of casting a "LOL" perhaps look into the issue that was raised by several users in these forums and fix the terrible performance of the product as it's been out for a year now yet the issue hasn't been solved since then.

Cheers,
Zsolt
george[flytampa]
Site Admin
Posts: 3469

Re: Very Low FPS on REBOOT KBOS

Post by george[flytampa] » Thu Feb 28, 2019 9:22 pm

Angrily whining how awful a job I've done over and over again, doesn't help me mate.

I'm running an i7 5820k & 1070GTX. Years old CPU & MB. No overclocking.
30fps at gate E8 in PMDGT7. I only get 45fps in this complex aircraft VC with nothing but ocean in view.
So why is your machine underperforming within the same scenery?
I have a six core chip v your faster four core. P3D might prefer more cores?
pmdgE8.jpg
pmdgE8.jpg (602.34 KiB) Viewed 2859 times
PS. Flytampa Montreal, you claim is 'properly optimized'.
It's actually only optimized the tiniest of fractions compared Boston.
Toronto wasn't recently changed performance-wise. If anything, the PBR shaders are currently slightly slower.
Our Toronto is generally slower than Boston. Due to, errr, the area.

Boston is a massive city. The suburbs sprawl out 15 miles or more. All that autogen from those ORBX packs might be the issue for you in these areas?

We better end it here thanks Zolt. You're not helping anyone with yet more derogatory adjectives.
There hasn't been many performance related issues with Boston's customer base I've noticed anyway.

If anyone can point out a BOS problem that could help improve the fps, I'd be happy to implement it.
zsolt.monostori
Posts: 17

Re: Very Low FPS on REBOOT KBOS

Post by zsolt.monostori » Thu Feb 28, 2019 9:54 pm

You certainly haven't done an awful job. KBOS looks stunning. However, performance wise it is way worse than any other scenery that I own and I see no reason why. I understand that the suburbs spread out 15 miles or more but Boston isn't the only city with suburbs that spread out that far. Autogen isn't any issue either, Boston isn't the most populated city in the P3D world, I do not see any issues anywhere else.

For testing purposes I fully disabled (so far I tried SPARSE) 3D people, static vehicles, landside traffic, snow drifts and this won me some FPS, now I get 25-27 FPS at gate E8 in the WS 787 facing ahead. I get over 30 with an all maxed out CYYZ at the gate facing the terminal.

I don't want to argue since it indeed won't help but for some reason KBOS performs very badly here and the reasons that you stated simply do not stand their ground as there are other complex areas, cities, airports that perform excellent, with the same settings.

Never mind, I have already given up on this scenery long time ago, once in a while it happens that the money you spend won't bring the joy you expect. Having bought hundreds of sceneries, one or two disappointment isn't the end of the world. Perhaps when I further upgrade my PC to NASA standards, I will revsit Boston. For now, it serves no other purpose than taking screenshots.
Senchai
Posts: 12

Re: Very Low FPS on REBOOT KBOS

Post by Senchai » Fri Mar 01, 2019 1:28 pm

zsolt.monostori wrote:It's very easy (and very professional, cough, cough...) to "LOL" upon a customer that purchased your product instead of looking for ways of fixing the issue. Basically, you grabbed a crappy default scenery for comparison from one certain angle. This isn't proof for anything. I tested without your KBOS installed (but still with FTX Global, Vector, OpenLC NA) installed and using the exact same settings that I always had and I got 55 FPS. How come I have more FPS with all these ORBX products installed than you, without anything... Now what? It still proves absolutely nothing.
Read this then Mr clever. See and learn, maybe. And learn to handle your sim/system. Seem you do a lot wrong toi get those numbers.

I find it really weird how different the sim runs for different people.

I know that im usually on the higher end of fps, doesnt matter what rig i was on in my sim "career". But its often enough that areas where others seem to have major issues (like KBOS) i cannt see the same in any way.

The same with Heathrow. THose 2 areas are absolutley no problem for me. I have (had) a pc with around same specs, a i7700k and a 1070, 16 GB ram running on a asus prime 7700k. KBOS ALWAYS were over 30 fps at any given time. Now with my RTX i even get 40 on the departure. THis is in VC in heavy planes like pmdg or comparable.

But then for me other areas make problems where other people dont have them. Like CYYZ. I see people have no issues here but this is one of the weaker addons for me, performance wise.

Of course i take other addons here into account. Like ActiveSky, regional ORBX scenery or anything like this. We always compare this in around same region. Or with people who have even less installed. And of course i also take configuration settings of the scenery itself into account.

All what follows should not be seen as bragging or defending developers, its just a report that shows people that it can be very different too, depending on things noone knows. yet.

Lets stay at KBOS. I run this together with the Aerosoft city scenery even and still get the names 30 to 40 fps in the vc on departure. I can post settings but i know that it wont help much for most. We went through this in our community with others already, without luck.

I really ask myself how the same sim can be so dramatically different on different installs/systems.

KBOS is way better in perf as many many other airports in the US. Really. Lets not even get the bad ones to compare here, like KJFK or KLAX. Because those 2 are the very worst i have ever seen.

I dont see any way for developers to do something here when the same sim runs completley different for people.

I post some pics now to show what i mean. Please rightclick on the pic and choose "open in another tab" if you see the picture in wrong format and cannot read things.

KBOS in the PMDG 748 (~55 fps outside view, ~34-40 fps vc)

Image

Image

Image

Image

Image

This is with SSAA, Tomatoshade, ActiveSky running and 50% UTLIve traffic

The very same i couldd say about Heathrow. Over 70 FPS in outside view and 40-50 fps in the VC. Again with SSAA and all the named addons.

Image

Image

This are the settings in the moment both airports where screenshotted. Not really very low settings really.

Image

Image

Image

Again, this is with a lot of addons like Tomatoshade, ActiveSky, REX Skyforce clouds/sky, UTLIve, Smartcars, ProjectFly, Chaseplane and whatnot.

So how can developers code airports to make them work for everyone? If there are ppl like me who have very good results even with most number of addons and high settings.

Probably now someone detects the RTX 2080 and thinks like "yeah... with that GPU he can has easy talk". Let me assure you that on my 1070 the results were not very far from this. Even around the same because that time i simply didnt use same high settings. Like i didnt use SS, lower reflections, a bit lower terrain and all this things. But the performance were ALWAY over 30 fps (in VC in a heavy plane with all addons running)

Intel 7700K (standard freq, no OC)
Nvidia RTX 2080, standard freq
Asus Prime Z270K
16 GB Ram (Ballistrix Sport 2666)
Win 10
Last edited by Senchai on Fri Mar 01, 2019 1:42 pm, edited 2 times in total.
Post Reply